Article 5F1X5 pinxi/inxi huge BSD updates, testers?

pinxi/inxi huge BSD updates, testers?

by
h2-1
from LinuxQuestions.org on (#5F1X5)
I bit the bullet and just redid big chunks of pinxi internally to enhanced BSD updates, I also managed to get more data working more reliably than ever before for FreeBSD, OpenBSD, NetBSD [never really had netbsd support in any real way before], and Dragonfly.

Since almost all my testing is on virtual machines, which have the same hardware profiles, the latest pinxi (the development version of inxi) would really benefit from some heavy testing from BSD users.

You can run pinxi alongside inxi, that's how it's designed to work, and you can install pinxi like so [change desired location to download to suite preferences, I prefer it in PATH to avoid having to remember where it is when I run it]. The only real dependency pinxi/inxi has is Perl5, so if you don't want to install that, this isn't for you.

# fast easy way:
using your favorite download tool: https://smxi.org/pinxi

Ex, OpenBSD/NetBSD: ftp -o /usr/local/bin/pinxi https://smxi.org/pinxi

which redirects to the github inxi-perl branch which is where pinxi lives. Avoid using git to grab it because that branch has a lot of other stuff in it, and all the branches have a ton of stuff together.

Added by request doas internal builtin support, along with sudo, either will work fine, but now pinxi is 'aware' of doas the same way it was of sudo, that was pretty easy to get working. Added usbconfig support, added pcictl support (netbsd), which I thought I had done, but hadn't. Added hammer support, which fixed some issues with disk sizes etc, and also cleaned up output in Partitions: -p report.

I'm particularly interested in the data you see with -Fazy and with -Jay (USB, which got a huge refactor to make it work better on BSDs), though -C, -D, -p, all saw big improvements for the BSDs, more data, subtle to not so subtle. Or just -zyv8 to show it all, filtered.

Note that it's very difficult for users to know when the data is correct or complete since you probably won't know the key things to look for.

Here's a sample from OpenBSD 6.8 [NetBSD is roughly similar in terms of what data is available, FreeBSD/Dragonfly are somewhat different], note the dmidecode errors, that's because dmidecode does not like running in a vm system, so I actually have no idea what works or does not work with dmidecode data. BSDs lean a bit more on dmidecode data than on linux, but I was glad to see a lot of the data sources are giving more data than before so I could fill in some missing areas.

With this many changes, and so many fixes for BSDs, I don't see how I could have not broken something that was working, though it was all slightly broken as it stood before these fixes, so any feedback is good.

Code:System:
Kernel: OpenBSD 6.8 amd64 bits: 64 compiler: N/A Desktop: FVWM dm: xenodm
OS: OpenBSD 6.8
Machine:
Type: Virtualbox Mobo: innotek model: VirtualBox v: 1.2 serial: N/A
uuid: 16d0d837-61e2-4143-b148-5be39e678fcb BIOS: innotek v: VirtualBox
rev: 2.5 date: 12/01/2006
Battery:
Unknown-error: Unknown dmidecode error. Unable to generate data.
Memory:
RAM: total: 1.98 GiB used: 136 MiB (6.7%)
RAM Report: unknown-error: Unknown dmidecode error. Unable to generate data.
PCI Slots:
Unknown-error: Unknown dmidecode error. Unable to generate data.
CPU:
Info: Single Core model: AMD Ryzen 5 2600 bits: 64 type: UP arch: Zen+
family: 17 (23) model-id: 8 stepping: 2 microcode: N/A cache: L1: 64 KiB
L2: 512 KiB L3: 16 MiB
Speed: 3400 MHz min/max: N/A
Core speed (MHz): No speed data found for 1 cores.
Features: 3dnowp abm aes amcr8 apic avx avx2 cflush clflushopt cmov cmpleg
cx16 cx8 de ffxsr fpu fsgsbase fxsr htt itsc lahf long masse mca mce mmx
mmxx movbe msr mtrr nxe pae pat pclmul pge popcnt pse pse36 rdrand rdseed
rdtscp sep sse sse2 sse3 sse4.1 sse4.2 sse4a ssse3 tsc vme xsave
Vulnerabilities: No CPU vulnerability/bugs data available.
Graphics:
Device-1: InnoTek VirtualBox Graphics Adapter driver: N/A bus-ID: 0:2.0
chip-ID: 80ee:beef class-ID: 0300
Display: server: X.org 1.20.8 driver: loaded: vesa alternate: vboxvideo
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel 82801AA AC97 driver: N/A bus-ID: 0:5.0 chip-ID: 8086:2415
class-ID: 0401
Sound Server-1: sndio v: N/A running: yes
Network:
Device-1: Intel 82540EM driver: N/A port: N/A bus-ID: 0:3.0
chip-ID: 8086:100e class-ID: 0200
Device-2: Intel 82371AB Power type: network bridge driver: N/A port: N/A
bus-ID: 0:7.0 chip-ID: 8086:7113 class-ID: 0680
IF-ID-1: em0 state: active speed: 1000baseT duplex: full-duplex
mac: <filter>
Bluetooth:
Message: No Bluetooth data was found.
Logical:
Message: No BSD support for LVM data.
RAID:
Message: No RAID data was found.
Drives:
Local Storage: total: 15.62 GiB used: 1.54 GiB (9.8%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/wd0 vendor: VirtualBox model: VBOX HARDDISK size: 15.62 GiB
serial: N/A
Optical-1: /dev/cd0 vendor: VBOX model: CD-ROM rev: 1.0 dev-links: N/A
Features: speed: Ultra-DMA mode 2 multisession: N/A audio: N/A dvd: N/A
rw: none state: N/A
Partition:
ID-1: / size: 412.9 MiB used: 82.5 MiB (20.0%) fs: ffs dev: /dev/wd0a
label: N/A uuid: N/A
ID-2: /home size: 2.55 GiB used: 70 KiB (0.0%) fs: ffs dev: /dev/wd0k
label: N/A uuid: N/A
ID-3: /tmp size: 545.5 MiB used: 12 KiB (0.0%) fs: ffs dev: /dev/wd0d
label: N/A uuid: N/A
ID-4: /usr size: 1.94 GiB used: 1.08 GiB (55.8%) fs: ffs dev: /dev/wd0f
label: N/A uuid: N/A
ID-5: /usr/X11R6 size: 530.2 MiB used: 234 MiB (44.1%) fs: ffs
dev: /dev/wd0g label: N/A uuid: N/A
ID-6: /usr/local size: 1.76 GiB used: 135.8 MiB (7.5%) fs: ffs
dev: /dev/wd0h label: N/A uuid: N/A
ID-7: /usr/obj size: 5.05 GiB used: 2 KiB (0.0%) fs: ffs dev: /dev/wd0j
label: N/A uuid: N/A
ID-8: /usr/src size: 1.34 GiB used: 2 KiB (0.0%) fs: ffs dev: /dev/wd0i
label: N/A uuid: N/A
ID-9: /var size: 782.1 MiB used: 9.8 MiB (1.2%) fs: ffs dev: /dev/wd0e
label: N/A uuid: N/A
Swap:
ID-1: swap-1 type: partition size: 639.7 MiB used: 0 KiB (0.0%)
dev: /dev/wd0b label: N/A uuid: N/A
Unmounted:
Message: No Unmounted partition data found for this BSD system.
USB:
Hub-1: 0-01:01 info: Apple OHCI root hub ports: N/A rev: N/A
chip-ID: 106b:0000
Sensors:
Platform: No OS support. Is a comparable Openbsd sensors tool available?
Repos:
Packages: pkg_info: 38 lib: 7
OpenBSD pkg mirror: /etc/installurl
1: https://cdn.openbsd.org/pub/OpenBSD
Info:
Processes: 49 Uptime: 22h 47m Init: init (BSD) v: N/A Compilers: gcc: 4.2.1
clang: 10.0.1 Shell: sh (doas) default: ksh v: 5.2.14_99/07/13.2
pinxi: 3.3.01-95latest?d=yIl2AUoC8zA latest?i=gvtpX6vHq1Q:c0RoV3dSylg:F7zBnMy latest?i=gvtpX6vHq1Q:c0RoV3dSylg:V_sGLiP latest?d=qj6IDK7rITs latest?i=gvtpX6vHq1Q:c0RoV3dSylg:gIN9vFwgvtpX6vHq1Q
External Content
Source RSS or Atom Feed
Feed Location https://feeds.feedburner.com/linuxquestions/latest
Feed Title LinuxQuestions.org
Feed Link https://www.linuxquestions.org/questions/
Reply 0 comments